All systems operational

Чтобы получать уведомления в Телеграм, подпишитесь на наш канал

Bot looping with BPL timers

Resolved
Degraded performance
Started about 1 year ago Lasted 3 months

Affected

TWIN
Сервис чатов
Updates
  • Resolved
    Resolved

    It's decided.

    BPL function with timers now takes into account the limit on the number of cycles in the script.

  • Investigating
    Investigating

    The BPL function with timers does not take into account the limit on the number of cycles in the start block.
    If a block with a BPL timer teleports to the same block, then this can cause a loop in the chat session, the bot will endlessly send messages (even when the active chat tab is closed or the bot is blocked in the messenger).
    This can lead to unwanted write-offs.

    We are actively working on a fix.